You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

79 lines
1.8 KiB

5 years ago
5 months ago
5 years ago
5 years ago
5 years ago
5 years ago
5 years ago
5 years ago
5 years ago
5 years ago
5 years ago
  1. {
  2. "name": "terminalizer",
  3. "version": "0.9.0",
  4. "description": "Record your terminal and generate animated gif images or share a web player",
  5. "main": "bin/app.js",
  6. "author": "Mohammad Fares <faressoft.com@gmail.com>",
  7. "license": "MIT",
  8. "homepage": "http://terminalizer.com",
  9. "repository": {
  10. "type": "git",
  11. "url": "https://github.com/faressoft/terminalizer.git"
  12. },
  13. "bin": {
  14. "terminalizer": "bin/app.js"
  15. },
  16. "scripts": {
  17. "dev": "NODE_ENV=development webpack --watch",
  18. "build": "NODE_ENV=production webpack --progress",
  19. "prepublish": "npm run build"
  20. },
  21. "keywords": [
  22. "terminal",
  23. "record",
  24. "capture",
  25. "tty",
  26. "shot",
  27. "bash",
  28. "powershell",
  29. "gif",
  30. "animated",
  31. "generate",
  32. "theme",
  33. "colors",
  34. "font",
  35. "repeat",
  36. "command-line",
  37. "shell",
  38. "zsh",
  39. "bash-profile",
  40. "render",
  41. "pty"
  42. ],
  43. "dependencies": {
  44. "async": "^2.6.3",
  45. "async-promises": "^0.2.2",
  46. "chalk": "^2.4.2",
  47. "death": "^1.1.0",
  48. "deepmerge": "^2.2.1",
  49. "electron": "17",
  50. "flowa": "^4.0.2",
  51. "fs-extra": "^5.0.0",
  52. "gif-encoder": "^0.6.1",
  53. "inquirer": "^6.5.2",
  54. "is_js": "^0.9.0",
  55. "js-yaml": "^3.13.1",
  56. "lodash": "^4.17.15",
  57. "node-pty-prebuilt-multiarch": "^0.10.1-pre.5",
  58. "performance-now": "^2.1.0",
  59. "pngjs": "^3.4.0",
  60. "progress": "^2.0.3",
  61. "request": "^2.88.2",
  62. "require-dir": "^1.1.0",
  63. "string-argv": "0.0.2",
  64. "uuid": "^3.4.0",
  65. "webdav": "^4.11.0",
  66. "yargs": "^12.0.5"
  67. },
  68. "devDependencies": {
  69. "ajv": "^7.2.4",
  70. "clean-webpack-plugin": "^4.0.0",
  71. "css-loader": "^1.0.0",
  72. "jquery": "^3.4.1",
  73. "mini-css-extract-plugin": "^2.6.1",
  74. "terminalizer-player": "^0.4.1",
  75. "webpack": "^5.74.0",
  76. "webpack-cli": "^4.10.0",
  77. "xterm": "^3.14.5"
  78. }
  79. }