Browse Source

Update to v7.1.2 (#155)

* Update to v7.1.2

* Try Node 16 again

Last time we tried to use this, we ran into all sorts of errors due to node-sass, which is used by the mattermost frontend.

I'm changing this because our build logs show NPM throwing a fit about not supporting Node 15, which we've been using. And the last several PR builds have errored out in NPM in weird ways that the internet keeps suggesting "just update NPM" to fix, so here we are.

ref: commit 69dda8131e
master v7.1.2
parnic-sks 3 weeks ago
committed by GitHub
parent
commit
b7c03a36af
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
  1. 2
      .github/workflows/release.yml
  2. 2
      build.sh
  3. 2
      dependabot/go.mod

2
.github/workflows/release.yml

@ -57,7 +57,7 @@ jobs:
- name: Set environment from runtime properties
run: |
echo "MATTERMOST_RELEASE=$(grep 'mattermost-server' dependabot/go.mod | cut -d' ' -f2)" >> $GITHUB_ENV
echo "MMCTL_RELEASE=v7.0.0" >> $GITHUB_ENV
echo "MMCTL_RELEASE=v7.1.2" >> $GITHUB_ENV
- name: Pull docker image
run: 'docker pull "${{ env.DOCKER_IMAGE }}"'

2
build.sh

@ -10,7 +10,7 @@ MATTERMOST_RELEASE="${MATTERMOST_RELEASE:-v5.26.0}"
MMCTL_RELEASE="${MMCTL_RELEASE:-v5.26.0}"
# node key id and release
NODE_KEY="${NODE_KEY:-9FD3B784BC1C6FC31A8A0A1C1655A0AB68576280}"
NODE_RELEASE="${NODE_RELEASE:-15}"
NODE_RELEASE="${NODE_RELEASE:-16}"
# golang version
GO_VERSION="${GO_VERSION:-1.18.1}"

2
dependabot/go.mod

@ -3,6 +3,6 @@ module github.com/SmartHoneybee/ubiquitous-memory/dependabot
go 1.18
require (
github.com/mattermost/mattermost-server/v6 v7.0.1
github.com/mattermost/mattermost-server/v6 v7.1.2
github.com/mattermost/mmctl v0.0.0-20211221153052-1bb2fec4c15e
)
Loading…
Cancel
Save