Browse Source

Update Mattermost and mmctl to 6.1.0 (#137)

pull/139/head v6.1.0
Pierre de La Morinerie 2 months ago
committed by GitHub
parent
commit
3aec2b6302
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
  1. 26
      build-release.patch
  2. 4
      dependabot/go.mod

26
build-release.patch

@ -1,8 +1,8 @@
diff --git a/build/release.mk b/build/release.mk
index 7f989d4b4..886119275 100644
index 017746342..3c3e76bea 100644
--- a/build/release.mk
+++ b/build/release.mk
@@ -71,7 +71,7 @@ package-prep:
@@ -99,7 +99,7 @@ package-prep:
@# Resource directories
mkdir -p $(DIST_PATH)/config
cp -L config/README.md $(DIST_PATH)/config
@ -11,12 +11,22 @@ index 7f989d4b4..886119275 100644
cp -RL fonts $(DIST_PATH)
cp -RL templates $(DIST_PATH)
rm -rf $(DIST_PATH)/templates/*.mjml $(DIST_PATH)/templates/partials/
@@ -201,7 +201,7 @@ else
cp $(GOBIN)/linux_amd64/mattermost $(DIST_PATH_LIN)/bin # from cross-compiled bin dir
@@ -159,13 +159,14 @@ else
cp $(GOBIN)/$(CURRENT_PACKAGE_ARCH)/$(MM_BIN_NAME) $(DIST_PATH_GENERIC)/bin # from cross-compiled bin dir
endif
#Download MMCTL for Linux
- scripts/download_mmctl_release.sh "Linux" $(DIST_PATH_LIN)/bin
+ cp "${HOME}/go/src/github.com/mattermost/mmctl/mmctl" $(DIST_PATH_LIN)/bin
+ @#Copy cross-compiled MMCTL
+ cp "${HOME}/go/src/github.com/mattermost/mmctl/mmctl" $(DIST_PATH_GENERIC)/bin
+
ifeq ("darwin_arm64","$(CURRENT_PACKAGE_ARCH)")
- echo "No plugins or mmctl yet for $(CURRENT_PACKAGE_ARCH) platform, skipping..."
+ echo "No plugins yet for $(CURRENT_PACKAGE_ARCH) platform, skipping..."
else ifeq ("linux_arm64","$(CURRENT_PACKAGE_ARCH)")
- echo "No plugins or mmctl yet for $(CURRENT_PACKAGE_ARCH) platform, skipping..."
+ echo "No plugins yet for $(CURRENT_PACKAGE_ARCH) platform, skipping..."
else
- #Download MMCTL for $(MMCTL_PLATFORM)
- scripts/download_mmctl_release.sh $(MMCTL_PLATFORM) $(DIST_PATH_GENERIC)/bin
@# Prepackage plugins
@for plugin_package in $(PLUGIN_PACKAGES) ; do \
ARCH="linux-amd64"; \
ARCH=$(PLUGIN_ARCH); \

4
dependabot/go.mod

@ -2,5 +2,5 @@ module github.com/SmartHoneybee/ubiquitous-memory/dependabot
go 1.16
require github.com/mattermost/mattermost-server/v6 v6.0.2
require github.com/mattermost/mmctl v6.0.0
require github.com/mattermost/mattermost-server/v6 v6.1.0
require github.com/mattermost/mmctl/v1 v6.1.0
Loading…
Cancel
Save