Browse Source

Update libsbsms to 2.2.0

Just a minor change that just bumps the libsbsms version.
au-ny-api
Leland Lucius 1 year ago
parent
commit
9543dd36c4
  1. 2
      cmake-proxies/CMakeLists.txt
  2. 4
      lib-src/audacity-patches.txt
  3. 6
      lib-src/libsbsms/ChangeLog
  4. 6
      lib-src/libsbsms/NEWS
  5. 20
      lib-src/libsbsms/configure
  6. 2
      lib-src/libsbsms/configure.ac

2
cmake-proxies/CMakeLists.txt

@ -150,7 +150,7 @@ addlib( lv2 lv2 LV2 NO YES "lilv-0 >= 0.24.6
addlib( portmidi midi MIDI NO YES "portmidi >= 0.1" )
addlib( portmixer portmixer PORTMIXER NO YES "" )
addlib( portsmf portsmf PORTSMF NO YES "portSMF >= 0.1" )
addlib( libsbsms sbsms SBSMS NO YES "libsbsms >= 2.1.0" )
addlib( libsbsms sbsms SBSMS NO YES "sbsms >= 2.2.0" )
addlib( soundtouch soundtouch SOUNDTOUCH NO YES "soundtouch >= 1.7.1" )
addlib( twolame twolame LIBTWOLAME NO YES "twolame >= 0.3.13" )

4
lib-src/audacity-patches.txt

@ -155,8 +155,8 @@ sbsms
https://github.com/claytonotey/libsbsms
An audio stretching library for changing pitch or tempo without changing the
other. Alternative to SoundTouch, better on large changes but slower.
Version in Audacity GIT: 2.1.0
Upstream Version: 2.1.0
Version in Audacity GIT: 2.2.0
Upstream Version: 2.2.0
soundtouch
----------

6
lib-src/libsbsms/ChangeLog

@ -0,0 +1,6 @@
libsbsms version 2.2.0 (01 Feb 2021)
First major release since migrating to GitHub.
Includes multiple bug fixes and optimizations since version 2.0.2.
Jan 18th 2021 libsbsms version 2.1.0 pre-release:
Repository migrated to GitHub.

6
lib-src/libsbsms/NEWS

@ -0,0 +1,6 @@
Feb 1st 2021:
libsbsms 2.2.0 released.
Jan 18th 2021:
libsbsms migrated to GitHub.
https://github.com/claytonotey/libsbsms

20
lib-src/libsbsms/configure

@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
# Generated by GNU Autoconf 2.69 for sbsms 2.1.0.
# Generated by GNU Autoconf 2.69 for sbsms 2.2.0.
#
#
# Copyright (C) 1992-1996, 1998-2012 Free Software Foundation, Inc.
@ -587,8 +587,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='sbsms'
PACKAGE_TARNAME='sbsms'
PACKAGE_VERSION='2.1.0'
PACKAGE_STRING='sbsms 2.1.0'
PACKAGE_VERSION='2.2.0'
PACKAGE_STRING='sbsms 2.2.0'
PACKAGE_BUGREPORT=''
PACKAGE_URL=''
@ -1319,7 +1319,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
\`configure' configures sbsms 2.1.0 to adapt to many kinds of systems.
\`configure' configures sbsms 2.2.0 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@ -1390,7 +1390,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
short | recursive ) echo "Configuration of sbsms 2.1.0:";;
short | recursive ) echo "Configuration of sbsms 2.2.0:";;
esac
cat <<\_ACEOF
@ -1502,7 +1502,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
sbsms configure 2.1.0
sbsms configure 2.2.0
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
@ -1901,7 +1901,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
It was created by sbsms $as_me 2.1.0, which was
It was created by sbsms $as_me 2.2.0, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
@ -15310,7 +15310,7 @@ fi
# Define the identity of the package.
PACKAGE='sbsms'
VERSION='2.1.0'
VERSION='2.2.0'
cat >>confdefs.h <<_ACEOF
@ -15957,7 +15957,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
This file was extended by sbsms $as_me 2.1.0, which was
This file was extended by sbsms $as_me 2.2.0, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@ -16023,7 +16023,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
sbsms config.status 2.1.0
sbsms config.status 2.2.0
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"

2
lib-src/libsbsms/configure.ac

@ -1,4 +1,4 @@
AC_INIT([sbsms],[2.1.0])
AC_INIT([sbsms],[2.2.0])
dnl Use the m4/ directory to contain libtool macros that will be needed to
dnl go with the ltmain.sh script (both will be created/updated via the command

Loading…
Cancel
Save